ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Clio 197 Turbo - Stuttering - EML



Edd

ClioSport Club Member
  Nav / Boxster / 197T
I don’t use my 197 Turbo much but it is booked in for injectors and remap tomorrow so I thought I’d bring it out of storage and give it a wipe down.

Driving home it didn’t feel right and the engine temperature seemed lower than usual (it has a digital read out).

Under acceleration it seemed to have a slight stutter through the rev range. Then the orange EML would flash for a minute or so.

The stuttering has affected performance.

It’s a Meg 225 conversion and any ideas/solutions on the above would be much appreciated.
 

JamesBryan

ClioSport Club Member
  Titanium 182
Flashing EML on our 225 was fuel injectors.

Be fine if you're having new ones put in.
 

Edd

ClioSport Club Member
  Nav / Boxster / 197T
What power did it make then?
It made 282bhp with the 630 injectors. To be fair it made 285bhp without the injectors so the map on it is quite conservative.

It was never about chasing numbers, it was about making something I could handle on track.

Paul pointed out a few issues with cooling and I’ll get them sorted, do a few track days and then maybe wind it up to 300.
 

OssPoop

ClioSport Club Member
That's the problem with a lot of these conversions. People obsess with 300 bhp and foal to get the bloody thing working properly first. Should be fun on track.
 


Top