Change background image
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horn Problem, Horn not working

Discussion in 'Faults, Problems & Solutions' started by kabz, Aug 27, 2008.

  1. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    Hi All,

    I have a clio dynamique 54 reg, horn not working on it, was working fine, 1 day used it coz sum muppet jus pulled out infront of me and was not working, checked fuses all fine

    any ideas what problem is? easy to fix? expensive?
     
  2. Sean6545

    Sean6545

    Joined:
    Feb 13, 2005
    Messages:
    2,190
    Location:
    Senior Tech at dealer in South West
    Car:
    Megane dci 130
    Broken wires behind the steering wheel 100%. You will need a new rotary switch. About an hours labour and about 50 quid off the top of my head.
     
  3. W111ALG

    W111ALG

    Joined:
    Dec 2, 2007
    Messages:
    602
    Car:
    172 Cup
    Mine stopped working and it was the connectors had came off at the horn behind th ebumper on the passenger side, reconnected and workiing fine.
     
  4. Adamhodg

    Adamhodg

    Joined:
    May 19, 2006
    Messages:
    3,871
    Location:
    Cheadle, Staffordshire
    Car:
    BMW 330D
    Same happened to mine.
    Id defo check their 1st before trying anything else.
     
  5. Dazdon

    Dazdon

    Joined:
    Oct 17, 2007
    Messages:
    298
    Location:
    Cumbria
    Car:
    Clio 172 CUP
    Mine too, bad earth in the end up. took it off and wire brushed everything up, put it back on and it worked fine!
    Phoned local Renault dealer the day b4 for some advice, *joke*, they also said it could be the rotary switch which they quoted me £82! Was thinking at the time that they had quoted me wrong as they also said that it would cost £70 + VAT for the actual horn itself if that was broke!

    Hope its just a bad earth like mine mate!
     
  6. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    thanks for all the help guys.

    how do i go about doing this then. i've had a look i cant really see much. where abouts is it behind the bumper?
    do i need to take the bumper off or can it be done with out taking the bumper off?? also any pics or anything of what it looks like, coz i dnt wanna mess up anything else.

    cheers
     
  7. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    any ideas where abouts behind the bumper , ive checked cant seem to see what im looking for. i checked behind bumper, behind tyre no joy.

    any help would be appreciated, as its due mot and i need get mot done and sell it asap.

    cheers
     
  8. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    is it near the fog lights by any chance. this is annoying me know. please help anyone
     
  9. Android

    Android

    Joined:
    Feb 17, 2007
    Messages:
    3,288
    Location:
    Kilmarnock, Scotland
    Car:
    Static Low
    ive gota 54 plate dynamiue too.

    horn also not working.
    hopefully covered under my warranty
     
  10. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    my warranty expired, gonna cost a bomb if i take it 2 renault thats why id rather get my hands dirty myself
     
  11. Darren S

    Darren S ClioSport Moderator

    Joined:
    Dec 30, 2004
    Messages:
    12,994
    Location:
    Bromley Cross
    Car:
    Black Gold 182
    Mine stopped working a few weeks before the warranty ran out. Reno fixed it, so unfortunately I'm not sure of the costs/bits involved.

    I think I'm right in saying that a non-working horn is an MOT failure as well. So if that's due soon, you may have to sort the horn out regardless?

    Hopefully it is an easy fix like others have said above!

    D.
     
  12. Tony Hunter

    Tony Hunter ClioSport Club Member

    Joined:
    Jul 23, 2006
    Messages:
    16,155
    Location:
    Burpspeed HQ Banbury,where else.
    Car:
    182cup & 172 racecar
    Give it a rub:wink:
     
  13. Josh@Renparts

    Josh@Renparts ClioSport Trader

    Joined:
    Dec 10, 2004
    Messages:
    7,212
    Location:
    Doncaster
    Car:
    www.renparts.co.uk
    nearly always faulty horn unit itself, seems to be prone to getting water in, best way to access is take the n/s arch liner out, then get a multimeter on it and get someone to press the horn so you can see if there is a feed. Or hook the horn up to 12v.
     
  14. kabz

    kabz

    Joined:
    Sep 4, 2006
    Messages:
    44
    Location:
    London
    Car:
    Clio Dynamique Black 3Dr
    just opened up the steering wheel, had a look everything seemed fine, gave it a whack and made a squeak, then nothing..... now as i was about the close the steering wheel giving up hope.. it beeped, pressed it again and nothing.... hope this helps any clues.
     
  15. Phill90

    Phill90

    Joined:
    Jun 11, 2008
    Messages:
    579
    Location:
    Quarry of the Bank
    Car:
    None
    Mine stopped working as well, Failed my Mot because of it
    Was told to see an Auto Electrician Which im doing tomorow so will let you no the price etc

    and Yours sounds like its wiring not the actual horn as it works.
    If you get two pieces of wire connect em to the battery probs need two people and your horn goes off you no which part is broken but yeah sounds like earthing
     

Share This Page