Change background image
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fitting New Speedo Sensor to Clio 172 ??

Discussion in 'Engine, Gearbox, Exhausts & Running Gear' started by goforboy, Oct 23, 2006.

  1. goforboy

    goforboy

    Joined:
    Apr 2, 2006
    Messages:
    11
    Car:
    RenaultSport clio 172 mk1
    Hi,

    I have a W-Reg Year 2000 Phase 1 Clio 172. The Speedo started to play up a few months ago, sometimes working sometimes not.

    I have accessed the sensor on the gearbox through the passenger side front wheel arch and checked and cleaned the connector (looked very clean anyway). This has made no difference.

    I have also checked the Speedo gauge with the dash test sequence and it works fine (even when the Speedo isn't working).

    I have also found that it fails more often at higher speeds, it never works on the motorway!

    So I have bought a new Speedo sensor from Renault (£25). How do I fit this? It looks like it might just pull out? Also do I need to grease the new one up before fitting it?

    Hope someone can help?

    Thanks,

    Regards

    Richard
     
  2. edde

    edde

    Joined:
    Apr 22, 2003
    Messages:
    29,458
    Just stick the new one it its a twist fit I think.
    Don't use grease.
    Check the wiring connection on the dash and sensor though instead they can be problematic.
     
  3. BenR

    BenR

    Joined:
    Dec 30, 2001
    Messages:
    22,342
    the sensor through the passenger wheel arch is the reverse gear sensor.

    Its easy to install, just push the tabs on the old one, pull out, and slot new one in. Its on the diff housing if you need to find it.
     

Share This Page