Change background image
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clio 172 esp and service light

Discussion in 'Faults, Problems & Solutions' started by mrgreedy, Oct 14, 2009.

  1. mrgreedy

    mrgreedy

    Joined:
    Oct 14, 2009
    Messages:
    2
    Car:
    clio 172
    hello just bought the car and after driving for 5 mins both lights come on and stay on?
    when i turn the car off they go away till 5 mins into the next trip
    please help
     
  2. Timmay

    Timmay

    Joined:
    Feb 3, 2006
    Messages:
    13,405
    Location:
    Behind You!
    Car:
    RB 200 Cup!
    loose airbag connector under the seat?
     
  3. kevin.s

    kevin.s

    Joined:
    Feb 12, 2008
    Messages:
    2,979
    Location:
    Birmingham/Tamworth
    Car:
    ibiza cupra
    yeah might be that. give it a wiggle and see if it does the trick. if not then you might have to get it on a diognostcs computer
     
  4. legohead01

    legohead01

    Joined:
    Apr 30, 2009
    Messages:
    586
    Car:
    clio 172 luna speedl
    abs sesor mate
     
  5. Daz Clio Cup

    Daz Clio Cup

    Joined:
    Feb 23, 2006
    Messages:
    2,416
    Location:
    Absolute Motorsport, Lincoln
    Car:
    TVR Cerbera
    is your ESP/Traction control turned off? The service light comes on on -JB- 's 172 when he has it turned off on track
     
  6. mrgreedy

    mrgreedy

    Joined:
    Oct 14, 2009
    Messages:
    2
    Car:
    clio 172
    The ESP is switched off, if it was airbag wouldn't it be the air bag light on, abs sensor sounds favourate is there one either side on front wheels? Any ideas on costs?
     
  7. Daz Clio Cup

    Daz Clio Cup

    Joined:
    Feb 23, 2006
    Messages:
    2,416
    Location:
    Absolute Motorsport, Lincoln
    Car:
    TVR Cerbera
    Like i said, IF the traction is OFF, then on -JB- 's 172 the SERV lght is on too after a short while.

    PM -JB- if you wanna ask him yourself
     
  8. seanybaby1788

    seanybaby1788 ClioSport Club Member

    Joined:
    Aug 20, 2009
    Messages:
    273
    Location:
    Erith
    Car:
    Arctic 182
    I had this a little while ago.

    Was a faulty Steering Angle Sensor
     
  9. iradek

    iradek

    Joined:
    Oct 13, 2009
    Messages:
    1
    Car:
    Renault Clio Sport 2.0
    same here....
    There is ESP sensor built-in the steering wheel, if your steering wheel is misaligned, or the sensor is faulty the SERV and ESP light will stay on.
     
  10. Jonny1*2

    Jonny1*2

    Joined:
    Jun 4, 2008
    Messages:
    8,879
    Location:
    Chorley, Lancashire
    Car:
    Powered by RSTuning
    have you don't anything with the discs recently? could be a faulty ABS sensor.
     
  11. Crossers

    Crossers

    Joined:
    Sep 12, 2009
    Messages:
    8
    Location:
    Manchester
    Car:
    182 Cup & Meg 225 F1 Team
    Could be the abs sensor, or you could have a split gator on the CV joint flinging grease on everything. This happened to mine. Quick clean up and all sorted.

    Simple problem either way, nothing to worry about.

    Paul
     
  12. P17 TOO

    P17 TOO

    Joined:
    Sep 14, 2009
    Messages:
    2,580
    Location:
    Long Stratton, Norfolk
    Car:
    438s Monaco
    If your ESP is switched off then the ESP light is going to be on as the whole point is the warning light tells you the ESP is off/not working...

    My suggestion turn the ESP on!
     
  13. Jonny1*2

    Jonny1*2

    Joined:
    Jun 4, 2008
    Messages:
    8,879
    Location:
    Chorley, Lancashire
    Car:
    Powered by RSTuning
    it turns itself on every time you switch the car off. so unless he's turning it off every time he starts up, it's not an issue. Plus service light wouldn't be on when you do this.
     
  14. Tigger

    Tigger ClioSport Club Member

    Joined:
    Dec 24, 2003
    Messages:
    17,218
    Location:
    North of Ireland
    Car:
    "Navy" N17 TWO
    Can anyone confirm that? :smile:
     
  15. superg72

    superg72

    Joined:
    Feb 2, 2011
    Messages:
    2
    Car:
    clio 172 sport
    i have the same problem only had the car a few weeks mine comes on sometimes though and not all the time
     
  16. gregknight

    gregknight

    Joined:
    Dec 29, 2009
    Messages:
    3
    Location:
    Isle of Wight
    Car:
    Clio 182
    Seems like a common fault as I also have this problem.
    Comes on whenever it wants, not particular driving duration/speed/knocks etc.
    I recently replaced the n/s lower ball joint so i suppose i could of inadvertently, damaged/knocked the abs sensor.
    Anyone actually fixed this problem and could let me know would be good
     
  17. navsin

    navsin

    Joined:
    Jul 28, 2014
    Messages:
    8
    Car:
    Clio Sport 182 Cup
    I just bought my car about a month or so ago and these lights randomly come on. They have come on around 3 times on 3 different occasions. And then when I start the car the next day they're not there, but might come back randomly another time I drive the car.. Does anyone have a definite answer as to what this is and the cost to fix it?

    Is it a problem?

    Thanks for the help. Its a shame this is my first post on this forum :worried:
     
  18. wag_7

    wag_7

    Joined:
    Nov 8, 2012
    Messages:
    92
    Location:
    Milton Keynes
    Car:
    Clio 182 FF
    I have this problem too! Very annoying. Cruise control keeps intermittently cutting out too? Related?

    Cheers
     

Share This Page