Change background image
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

02 Clio - Loss of power & Electrical fault on dashboard

Discussion in 'Clio Discussion' started by zabius, Sep 6, 2011.

  1. zabius

    zabius

    Joined:
    Sep 6, 2011
    Messages:
    1
    Car:
    2002 Renault Clio
    Hi guys,


    Some background info first - I have a 2002 Renault Clio 1.2 that has almost 70k on the clock. It is serviced at least once every year.


    While driving on the motorway one day I noticed the 'Electronic fault & preheating warning light' come on. Almost immediately I could feel the car losing power.


    The dashboard light looks like the following image :-
    [​IMG]


    The car has been in & out the garage - forked out some money too - they bought me a used throttle potentiometer sensor and installed this but this hasn't made any difference.


    The car itself drives however once the car starts moving this light comes on fairly quickly. The car starts to 'kangaroo' and all I can do is turn off the car. Once I restart the car it jumps/kangaroos quite violently to the point I have to turn off the car and let it cool down for a few minutes (apparently waiting 5 mins or so has been recommended so it clears out any remaining error codes).


    The garage have stated they can do no more but believe the issue is ECU related. Would it be possible to simply remove an ECU from one 02 Clio to another 02 Clio?


    What steps do people think I should try next? The electronic problems with Renault cars seem really common, can anyone suggest my next step in hopefully fixing my car?
     

Share This Page